Liberty BASIC Community Forum
« Icon Editor error »

Welcome Guest. Please Login or Register.
Jul 24th, 2017, 7:41pm


Rules|Home|Help|Search|Recent Posts|Notification

Problems installing Liberty BASIC? Read the Vista/Win7 Installation FAQ
Looking for a categorized List of Bug Reports? Visit the Liberty BASIC Bug Tracker

« Previous Topic | Next Topic »
Pages: 1  Notify Send Topic Print
 thread  Author  Topic: Icon Editor error  (Read 284 times)
ombre
New Member
Image


member is offline

Avatar




PM

Gender: Male
Posts: 29
xx Icon Editor error
« Thread started on: Jul 2nd, 2017, 6:40pm »

When I run «icon editor» right after I start LB 4.5.1 in Windows 10 , I get this error message: «Runtime Error: graphicsMedium" not understood», though the Icon Editor comes on anyway. If I close Icon Editor and run it again, the error message does not appear
User IP Logged

CarlGundel
Administrator
ImageImageImageImageImage


member is offline

Avatar

author of Liberty BASIC


Homepage PM


Posts: 2830
xx Re: Icon Editor error
« Reply #1 on: Jul 3rd, 2017, 11:02am »

Does this happen with v4.5.1 Pro, or with the non-Pro version?

-Carl
User IP Logged

author of Liberty BASIC
http://www.libertybasic.com
BeeTrap
New Member
Image


member is offline

Avatar




PM

Gender: Male
Posts: 20
xx Re: Icon Editor error
« Reply #2 on: Jul 3rd, 2017, 12:13pm »

I just tried:
Liberty BASIC v4.5.1
Liberty BASIC Pro v4.04
Liberty BASIC Pro v4.5.1
and get the same error mentioned on all three.
User IP Logged

CarlGundel
Administrator
ImageImageImageImageImage


member is offline

Avatar

author of Liberty BASIC


Homepage PM


Posts: 2830
xx Re: Icon Editor error
« Reply #3 on: Jul 3rd, 2017, 12:37pm »

Hmm. Works fine for me. Do you have any printers installed by any chance? This sort of problem has always been a side effect of there being no printer installed.

-Carl
User IP Logged

author of Liberty BASIC
http://www.libertybasic.com
ombre
New Member
Image


member is offline

Avatar




PM

Gender: Male
Posts: 29
xx Re: Icon Editor error
« Reply #4 on: Jul 3rd, 2017, 2:38pm »

I have the non-pro version of 4.5.1

I also have many printers installed.

I tried it with Windows 7 on an other computer and the same problem occurs
« Last Edit: Jul 3rd, 2017, 2:39pm by ombre » User IP Logged

Jim Hiley
Full Member
ImageImageImage


member is offline

Avatar




PM


Posts: 201
xx Re: Icon Editor error
« Reply #5 on: Jul 5th, 2017, 6:05pm »

I can repeat the error. V4.5.1 standard on W10 Home. Installed printer is a network printer.

Error occurs on the first call to Icon editor after a program startup.

Error log:
Code:
Error log timestamp Thursday 06/07/17 08:59:25

Runtime error: "graphicsMedium" not understood

MessageNotUnderstood>>defaultAction
MessageNotUnderstood(Exception)>>activateHandler: <anUndefinedObject> 
MessageNotUnderstood(Exception)>>handle
MessageNotUnderstood(Exception)>>signal
MessageNotUnderstood class>>message: <aMessage> 
UndefinedObject(Object)>>doesNotUnderstand: <aMessage> 
IconEditor>>clear
Message>>perform
Message>>evaluate
TopPane(Object)>>triggerEvent: <#opened> 
TopPane>>triggerOpenedEvent
Message>>perform
NotificationManager>>runPendingEvents
NotificationManager>>runEventLoop
Message>>perform
Message>>evaluate
Process>>safelyEvaluate: <aMessage> 
Process>>evaluate: <aMessage>  

Jim

Edit: I just tested V4.04Pro - the problem occurs there also!
It's a long time since I used the Icon Editor.
« Last Edit: Jul 5th, 2017, 6:10pm by Jim Hiley » User IP Logged

Rod
Global Moderator
ImageImageImageImageImage


member is offline

Avatar

Graphics = goosebumps!


PM

Gender: Male
Posts: 5366
xx Re: Icon Editor error
« Reply #6 on: Jul 6th, 2017, 02:37am »

I get the same, second call works without error. Win10 V4.5.1

I too have a wireless network printer which sits offline most of the time.
« Last Edit: Jul 6th, 2017, 02:41am by Rod » User IP Logged

CarlGundel
Administrator
ImageImageImageImageImage


member is offline

Avatar

author of Liberty BASIC


Homepage PM


Posts: 2830
xx Re: Icon Editor error
« Reply #7 on: Jul 6th, 2017, 4:33pm »

on Jul 3rd, 2017, 2:38pm, ombre wrote:
I have the non-pro version of 4.5.1

I also have many printers installed.

I tried it with Windows 7 on an other computer and the same problem occurs

Is your default printer a network printer?

-Carl
User IP Logged

author of Liberty BASIC
http://www.libertybasic.com
ombre
New Member
Image


member is offline

Avatar




PM

Gender: Male
Posts: 29
xx Re: Icon Editor error
« Reply #8 on: Jul 8th, 2017, 08:13am »

No, but it's wireless
User IP Logged

CarlGundel
Administrator
ImageImageImageImageImage


member is offline

Avatar

author of Liberty BASIC


Homepage PM


Posts: 2830
xx Re: Icon Editor error
« Reply #9 on: Jul 8th, 2017, 09:25am »

on Jul 8th, 2017, 08:13am, ombre wrote:
No, but it's wireless

Wireless as in Wifi? Unless I'm missing something, a wifi printer is a network printer.

-Carl
User IP Logged

author of Liberty BASIC
http://www.libertybasic.com
ombre
New Member
Image


member is offline

Avatar




PM

Gender: Male
Posts: 29
xx Re: Icon Editor error
« Reply #10 on: Jul 8th, 2017, 6:00pm »

Sorry ||

My mistake
User IP Logged

Dan Teel
Guru
ImageImageImageImageImage


member is offline

Avatar




Homepage PM

Gender: Male
Posts: 1130
xx Re: Icon Editor error
« Reply #11 on: Jul 8th, 2017, 10:45pm »

I have no printer, and I even get the error.

Windows 10 64bit
User IP Logged

ZPtr.net
Pages: 1  Notify Send Topic Print
« Previous Topic | Next Topic »

Rules|Home|Help|Search|Recent Posts|Notification

Liberty BASIC Community Wiki
Wikispaces
Donate $6.99 for 50,000 Ad-Free Pageviews!

| |

This forum powered for FREE by Conforums ©
Sign up for your own Free Message Board today!
Terms of Service | Privacy Policy | Conforums Support | Parental Controls